Zeppelin Design Labs

MIDI not working

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  zdlAdmin 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #6787 Reply


    I finished assembly of the Altura, and all of the tests worked perfectly. However, when connected to my workstation via a standard MIDI to USB cable, there is no MIDI output, although the display indicates activity. The activity LED on my cable shows no MIDI output, as does the workstation. The cable works fine with 2 keyboards. I checked the circuit pathway from the MIDI connector to the MP and that is OK. I also checked the voltage on the MIDI output pin, it measures 5 volts at startup and varies only slightly when I “wave”. The serial number is ZD3073 (version 2.4). Thanks!

    #6833 Reply


    Howard, sorry for the delayed response; too much pumpkin pie this weekend.
    It sounds like you did some good troubleshooting. Here are a couple more things to check, to help us narrow this down.

  • First, be sure the Altura is NOT in X-Y mode during testing; it’s a little trickier to set up. Leave it in Function 2 so the left hand controls the mod wheel and right hand sends notes. Also set DATA NEAR and FAR to 0 and 127; set OCTAVE NEAR and FAR to 5 and 6 or so. This assures you will send easily=perceived effects.
  • Please connect the Altura directly to one of your keyboards, using just a standard MIDI cable. Make sure the Altura transmit channel (Function 7) is set the same as the keyboard RECEIVE channel, or that the keyboard is in OMNI mode. Can you make the MIDI light blink on the keyboard? Can you hear stuff?
  • Let us know what you get.


#7186 Reply


Hi Glen. Sorry for the long delay, but I was at my cottage and the standard MIDI cable was at home.
As soon as I arrived home yesterday, I hooked up the Altura to my old Casio keyboard per your suggestions. It worked perfectly! I stopped working for a bit and played instead. This thing is great! Back to work–I again tried to get the Altura to work as an instrument on my computer workstation, connected by a MIDI to USB cable. I first connected the Casio keyboard to the workstation. The workstation reports a MIDI device connected, and the Casio keyboard then plays fine through the workstation. There is a MIDI activity lamp on the USB cable which blinks when MIDI commands are sent. Then I disconnected the cable end at the Casio and plugged it into the Altura. The workstation indicates that it detected an instrument, but no sound plays, and the MIDI activity lamp on the cable stays dark as I play the Altura. Switching back to the keyboard, the workstation reports the change, and the keyboard again plays and the MIDI activity lamp blinks. I also tried plugging the cables in and then reloading the workstation each time, in case plugging and unplugging was confusing the workstation.
I would suspect the MIDI to USB cable, but it works fine with my old keyboard! Not quite there yet…

#7189 Reply


Wow HGoward, good work. Let me think about this a little.

#7447 Reply


Hi Glen: After checking everything many times, I took a look at cables on Amazon. They had 2 styles of USB-MIDI cables, cheap ($9) and expensive ($23). I own the cheap version, so I bought an expensive one. It arrived yesterday and I plugged it in. It worked perfectly! Apparently, you get what you pay for with MIDI cables. The project is complete and ready in time for Xmas! Thanks for your support Glen.

#7448 Reply


Howard, that’s good to hear. Yeah, we had to learn the same lesson the same way. Merry Christmas everyone!!

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: MIDI not working
Your information:

avant-garde audio & electronic products