Zeppelin Design Labs

Synth not working (Troubleshooting Help)

Home Forums Macchiato Mini Synth Forum Macchiato FAQ & Support Synth not working (Troubleshooting Help)

This topic contains 10 replies, has 3 voices, and was last updated by  Nate 1 month, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1993 Reply

    Jeremy

    I finished soldering the DIY kit of the Macchiato Synth, but get no sound. I have read the quickstart guide, and tried tweaking the knobs even randomly to no avail. The power LED comes on properly, but that’s it for output. I have checked my connections and parts, and they all seem to be the right parts in the right spots with properly soldered connections.

    Are there any known issues to watch out for, parts I should try replacing, or software glitches?

    My first guess is maybe when I soldered it too much heat got to the 2 IC’s. If nothing else works, I guess I’ll try replacing them with IC sockets and new IC’s.

    #2014 Reply

    zdlAdmin
    Keymaster

    Holy Cannoli Jeremy! We’ve had some trouble with our Forum Notifications routine, and your post escaped our attention. Pray tell, how’s that Macchiato of yours? Still silent? What’s the serial number? Do I understand you get no sound from either the onboard speaker or through the headphone jack? Among the possible explanations are 1) a damaged component, as you noted; 2) an undetected broken solder joint along the critical signal path, probably somewhere from the volume pot to the point where the signal splits between the speaker and the jack. I’ll have Brach, the Macchiato’s designer, chime in tomorrow. Sorry for the delay.

    Glen

    #2051 Reply

    Giovanni

    Same here. Just finished building the DIY kit. The LED turns on, but no sound is produced, either by the speaker or by the headphones. Any suggestion?

    Thanks
    Giovanni

    #2057 Reply

    brach
    Moderator

    Giovanni,
    Sorry for the late response.
    In reference the “quick start guide”…First of all make sure the depth, attack, and release knobs is all the way to the left. Plug in headphones or computer speakers and then test it again. If you still can’t hear any sound, then double check your solder joints in the audio section of the circuit board…which is all the components connected to the LM396 amplifier chip. Make sure everything is connected properly and nothing is connected that shouldn’t be.
    If you still can’t figure it out, let me know and we’ll start looking at the voltages around the audio section to see if everything is functioning properly.
    Good luck.
    -Brach

    #2541 Reply

    Katherine

    Have had the same issue as well with my DIY kit 🙁

    The LED does turn on, but no sound is produced (speaker or headphones). Saw the prior recommendations and tried the suggested configuration of knobs with no luck.

    I looked at the the solder joints in the audio section around the LM396 chip and didn’t see any issues, is there a better way I should be checking these? If not, what’s the next step in trouble shooting this?

    Thanks for any help!

    Katherine

    #2542 Reply

    zdlAdmin
    Keymaster

    Katherine (and others): there is a very slim possibility that we shipped a few units with no software on them at all! This, of course, would account for No Sound. The most direct solution is to download the latest software from our Github page and flash it to your Macchiato. If you have never done this sort of thing, you may want to find an Arduino-enthusiast friend, who will be able to do this with both eyes tied behind his back. Otherwise, obtain a USB-Tiny programmer and the AVRDUDE utility. Follow the Github instructions.

    If you do not want to mess with this, write to us at info at zeppelindesignlabs dot com and we’ll work it out.

    #6741 Reply

    Nate

    My girlfriend and I spent a lot of our own time re-checking solder joints, component values and their orientations thinking we had assembled the kit incorrectly. The red light turned on but nothing else happened. Turns out Zeppelin never programmed the Arduino chip on our synth. I had to pay another $17 to get their programmer and do it myself. Such a frustrating experience

    #6747 Reply

    zdlAdmin
    Keymaster

    Nate, I am very sorry to hear this! I know all to well the pain of frustration. Do I understand that you successfully re-flashed the synth? Did this work? Please respond with your synth serial number. This is super-important for us to figure out what may have happened to your synth. The three units described in this (pretty old) thread were result of an isolated incident, and all affected units are accounted for. It is therefore unlikely the problem with your unit was that it shipped with no software at all; there are a few other possibilities with DIY kits.
    Again, so sorry.

    #6753 Reply

    Nate

    Yes, I re-flashed and then my synth was able to make noise. SN is ZD2214

    #6755 Reply

    zdlAdmin
    Keymaster

    Holy Hotsauce, Nate! That unit’s serial number is right smack in the middle of the others in this thread! I guess all those problematic units were NOT “accounted for”!! Guess where your kit spent a year, laying low while we were sorting out these other units? In an English customs house. I am refunding your purchase price of the USB-Tiny right now.

    Incidentally, we just updated the Macchiato software today, to add the ability to set its MIDI receive channel. If you are using the Macchiato with an external keyboard controller, you may find that useful. It’s version 1.2.2. Follow the instructions in the ZDL Updater Help to “run as administrator”, and it will fetch the latest update for you.

    I again apologize for the hassle.

    Glen van Alkemade

    #7060 Reply

    Nate

    Wow. What are the odds? Thanks for the refund!

    That’s a great feature for running this synth alongside my other gear. I’m only seeing the older release 1.1.3 on the github page. Where do I get 1.2.2 to update via my Mac? Are there instructions on how to set the channel? I’d love to see all the changes from 1.1.3 to 1.2.2 as well. Are those available?

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: Synth not working (Troubleshooting Help)
Your information:




avant-garde audio & electronic products